WDCP 切换PHP版本不成功 始终是原来的php5.2【已解决】

WDCP 切换PHP版本不成功 始终是原来的php5.2【已解决】

建站优化2019-02-23 0:3112550chengxianrui

昨天安装 PHP版本折腾了一天,好不容易安装好了。

http://www.chengxianrui.com/post/316.html  但是,在WDCP里面切换,又成了问题。

安装了 7.1    7.2 ,无论你怎么切换,人家就是认准 5.2,死活不改。

百度了很久,也没个具体的解决方法。

今天,误打误撞的,搞定了。但是,更换的不是 7.2,而是 5.6~~~

我以为,应该是这个原因:

1,目前,我的数据库是 MYSQL ,而 当你升级太高的 PHP版本之后,由于架构的问题,导致不能跟你的 数据库链接,所以会出错,而WDCP,干脆 就没有任何提示,就是切换不成功(确切的说,是WDCP提示成功了,但是实际网站没有切换)

如果,会 搞 MYSQL的话,试着吧 MYSQL 变成 mysqli  ,然后配置文件里改一下,应该可以吧。

2,我退而求其次了,因为不能使用高版本的PHP,所以,试了一下  5.6,跟之前一样,下载安装。WDCP里面,启动。

image.png

兴奋的刷新了一下网站,但是,还是 5.2,于是,更改了一下 引擎设置:

image.png

改成  nginx+apache  提交之后,刷新了一下网站后台~~

NND,折腾了我两天两夜的问题,终于又了眉目!成功!

image.png

我可就是为了买这个插件呀!!!!终于可以了~~~想哭!

-----------------------------------------------

加了同样问题的朋友,QQ给出了这样的解决方法,也可以参考一下:

image.png

原文地址:https://blog.csdn.net/DBCai/article/details/84992861  


可能,还是具体问题要具体分析解决的,原因真的是很多种。

取消

感谢您的支持,我会继续努力的!

扫码支持
扫码打赏,你说多少就多少

打开支付宝扫一扫,即可进行扫码打赏哦

 

除特别注明外,本站所有文章均为程显锐原创,转载请注明出处:http://www.chengxianrui.com/post/318.html

 


程显锐 Copyright © 
读书笔记 · 二维码生成 ·
公安备案:32050602010770 · 黑ICP备15009090号-2 本站部分视频和图片来源于网络,如果无意侵犯了您的权益,请您及时联系站长 QQ:20775654 我会及时处理。
引用一句话:等不需要等周末就可以自由支配时间,我们也就被时间死死的钉在砧板上等待夕阳的宣判...
所以有周末可盼,说明你还年轻。